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Learn how to use IRender nXt to create stunning images from your SketchUp models.Turn your
SketchUp designs into beautifully rendered, high-resolution images.Add lights, materials, skies,
etc. to create Photorealistic renderings directly from SketchUp.Create photo-realistic, still,
panorama and animation images files from 3D models using raytracing and radiosity
technologies.This reference manual has Tutorials, explanations of rendering terms, and specific
instructions for Wizards to help you use nXtRender for IRender nXt.Step-by-step examples will
make it easy to learn how to render with SketchUp.Examples, Images and information on
rendering terms and capabilities which you can use to improve your renderings.
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17.3 - Support DialogIndex- Getting StartedIRender nXt is an easy to learn plugin for creating
photorealistic renderings right inside SketchUp. Watch our getting started with IRender nXt
video.Get started with an overview of Rendering, Installation, Licensing and some video
tutorials.Sala 020612 by Jorge Javier Lara Dominquezis an easy to learn, yet powerful plugin for
creating photorealistic renderings from right inside SketchUp. If you can draw it in SketchUp, you
can render it with IRender nXt.Downloading & installing.See: How to Download and InstallIf you
have any problems downloading or installing your IRender trial software, we’re here to help.
Contact us at support@renderplus.comTrial VersionThe IRender nXt trial is a fully functional
version with no watermarks or limitations. You may use it free for 30 days.See: a full license at
any time.[[Image:Lets get started.gif]Videos and TutorialsThe has videos for you to use to get
started and on-line documentation to accompany many of the videos.First Exterior
RenderingSimple Rendering of an ObjectAdvanced IRender nXt FeaturesInterior Lighting
BasicsLighting ChannelsRendering with Edge LinesReflection SettingsGlass
TransparencyMultipass RenderingHow to choose a rendererPurchaseat any time.No need to
wait until your trial is over, you can purchase an IRender nXt full user license at anytime. Multi-
seat and network licenses are also available. Contact sales@renderplus.com with
questions.Problems - Contact Us - Don't Give UpIf you are trying IRender nXt for the first time,
and have problems, Don't Give Up.Between the combinations of SketchUp versions, Windows
versions, and machine types, sometimes somethings goes wrong. It anything is not working,
don't give up. Let us know.If you have problems with downloads or installation, contact us right
away at support@renderplus.com.If you have other problems, or questions on how to use
IRender nXt, place them on our .Download Problems - If the download doesn't start, try again.
Sometimes our download service gets messed up, If is still doesn't start email us and we will
send you a direct link to try.Installation - During installation, you need to select the proper version
of SketchUp. If you have problems contact us right away.SketchUp Toolbar - If the application
does not appear on the SketchUp tool bar - look under plugins. If there is an entry called IRender
Load', click it.Other Problems - - Contact Us - Don't Give Up.|}Other Tutorials[[IRender Tutorial -
Getting StartedDrawing a simple room]]- Getting StartedIRender nXt is an easy to learn plugin
for creating photorealistic renderings right inside SketchUp. Watch our getting started with
IRender nXt video.Get started with an overview of Rendering, Installation, Licensing and some
video tutorials.Sala 020612 by Jorge Javier Lara Dominquezis an easy to learn, yet powerful
plugin for creating photorealistic renderings from right inside SketchUp. If you can draw it in
SketchUp, you can render it with IRender nXt.Downloading & installing.See: How to Download



and InstallIf you have any problems downloading or installing your IRender trial software, we’re
here to help. Contact us at support@renderplus.comTrial VersionThe IRender nXt trial is a fully
functional version with no watermarks or limitations. You may use it free for 30 days.See: a full
license at any time.[[Image:Lets get started.gif]Videos and TutorialsThe has videos for you to
use to get started and on-line documentation to accompany many of the videos.First Exterior
RenderingSimple Rendering of an ObjectAdvanced IRender nXt FeaturesInterior Lighting
BasicsLighting ChannelsRendering with Edge LinesReflection SettingsGlass
TransparencyMultipass RenderingHow to choose a rendererPurchaseat any time.No need to
wait until your trial is over, you can purchase an IRender nXt full user license at anytime. Multi-
seat and network licenses are also available. Contact sales@renderplus.com with
questions.Problems - Contact Us - Don't Give UpIf you are trying IRender nXt for the first time,
and have problems, Don't Give Up.Between the combinations of SketchUp versions, Windows
versions, and machine types, sometimes somethings goes wrong. It anything is not working,
don't give up. Let us know.If you have problems with downloads or installation, contact us right
away at support@renderplus.com.If you have other problems, or questions on how to use
IRender nXt, place them on our .Download Problems - If the download doesn't start, try again.
Sometimes our download service gets messed up, If is still doesn't start email us and we will
send you a direct link to try.Installation - During installation, you need to select the proper version
of SketchUp. If you have problems contact us right away.SketchUp Toolbar - If the application
does not appear on the SketchUp tool bar - look under plugins. If there is an entry called IRender
Load', click it.Other Problems - - Contact Us - Don't Give Up.|}Other Tutorials[[IRender Tutorial -
Getting StartedDrawing a simple room]]How to Download and InstallStep 1: DownloadDownload
from SiteGo to www.renderplus.com. Then click on the ‘Downloads’ tab.Or click on this
URL:click on either the ‘Try it’, ‘Buy it’ or on the ‘Downloads’ tab.Fill out FormFill out the form and
select the download desired.click on the ‘Request Download Link’.Select desired productJust
click on ‘Download’ under the name of the software you want.Download the file to some place
on your computer you know and is easy you get to, like your desktop.Select tje product to
download.Step 2: Locate the Downloaded FileWhen you download a product your browser
prompts you to choose a location to save the software. If you cannot remember where you saved
the files, try the following solutions.Check the browser's download locationCheck the location
where your browser automatically saves downloaded files:Internet Explorer (Windows): C:\...
[user name]\My Documents\DownloadsFirefox: Choose Firefox > Preferences (Mac OS) or Tools
> Options (Windows). In the General tab, look in the Downloads area. Check the setting Save
Files To to see the download location.Safari (Mac OS): Choose Safari > Preferences. In the
General tab, check the setting Save Downloaded Files To.Google Chrome: Choose Customize
and Control Google Chrome>Options. In the Under The Hood tab, look under the Downloads
heading. Check the Download location setting.Check the Downloads window (Firefox, Safari,
Chrome)Firefox and Safari track the progress of files they download. If Firefox or Safari managed
the download (not Akami or Adobe Download Assistant), check the Downloads window for the



location of your downloaded files.Firefox: Choose Tools > Downloads or press Ctrl+J (Windows)
or Command+J (Mac OS). Right-click (Windows) or Control-click (Mac OS) the downloaded file
and choose Open Containing Folder (Windows) or Show In Finder (Mac OS).Safari (Mac OS):
Choose Window > Downloads or press Option+Command+L. Control-click the downloaded file
and choose Show In Finder.Google Chrome: Choose Customize and Control Google
Chrome>Downloads or press Ctrl+J. Click the Show in folder link under the downloaded
file.Step 3: InstallOpen Downloaded File5. Then double click on the file to open it. Then click on
the only file there called ‘Click here to install"click on ‘Click here to install".Follow Steps to
Install6.Next, just follow the steps to install the software on your computer.Install software.Step
4: Load Plugin in SketchUpStart Product from Plugins TabOpen SketchUp.After you download
and install the software, you are ready to use it.Most products will automatically load into
SketchUp. If the product does not appear, check to see if it is available on the Plugins Tab.If it
does not appear, check the SketchUp Preferences/Extensions WIzard. See:Also, check that the
Toolbar is enabled undef View/Toolbars.If you don’t still don't see the product, reinstall it.click on
‘plugins’ to open software.SketchUp Extensions and Toolbar VisibilitySketchUp Extensions
Wizard.SketchUp Toolbars.ProblemsIf the application does not show up in SketchUp, or in the
SketchUp Plugins menu, try these steps:- Create and Render a Basic RoomThis IRender
Tutorial will take you through the basic steps of Render nXt 's rendering engine.Downloads and
InstallationThere is a 30 day Trial Version for RPS products. This is a fully functional version, with
watermarks or other text added to indicate that it is a trial version.Follow the links on the to
download the latest version.See: How to Download and InstallStart SketchUpWhen SketchUp
starts,Click "IRender_nXt load" from the Plugins menu.The IRender_nXt should appear:If it does
not appear, go to the menu "Window/Preference/Extensions" and make sure the IRender_nXt is
checked.Do a test renderingWith a very small drawing, or just "Bryce" in the empty drawing,
click the "Render" icon.Render - starts a new ray trace of your current model and settings.This
will load the Rendering Settings dialog.For now, ignore the settings and click Start
RenderingThis should create a rendering of your drawing.(It will not be very exciting because
there are no lights or reflections.Step 1 - Get Basic RoomEither create a simple room, orClick
Open Sample Models ( ) to bring up the 'Load Sample Drawing' dialog and Pick 'Sample Room
for Tutorial'This model is also stored in the 3D Warehouse:.Click Render ( ) to render the
room.Step 2: Make the floor reflectiveRight click on the floor and select Edit Material .In the
'Reflection and Highlight' box, slide the 'Intensity' slider to 0.75.Click OKRender again. ( )Step 3
- Adding a mirrorCreate Mirror will create a mirror component for you to place in the
drawing.Select the Create Mirror Component icon: ( )Set the 'Reflection' slider to 95%.Click
Create and Place to place the mirror in your drawing.Render the model.Add mirrors to the
drawingRay Trace image with mirrorsFor more information on reflective materials, see
the .Adding lightsIRender works withStandard SketchUp lights.Custom light fixtures created with
the Light Fixture WizardIn addition, you can make your own lights by placing lamps in these or
other components.Step 4 - Create table & floor lampsFirst, add a table lamp:Click the Create



Light Fixture icon ( ). The 'Light Fixtures' dialog will appear.Select the 'Table' tab to create a
table lamp.On this tab, you can set the type and color of the shade and base, the physical
dimensions of your lamp and its parts, and the intensity and color of the light emitted.In the
'Component Placement Mode' box, select 'Single'.Click Create Lamp to create the lamp
component and place it in your model.Now to add a floor lamp:Open the 'Light Fixtures' dialog
again and select the 'Floor' tab.Here you can customize the lamp, as with the table lamp.Select
single placement mode, click Create Lamp, and place a floor lamp.Render again. ( )Rendering
with LightsStep 5 - Create Spot and Point lightsTo make it easier to see the spotlight and point
light we are about to place, delete the lamps from step 4. First, we will create a spotlight:Open
the 'Light Fixtures' dialog again and select the 'Spot' tab.Set 'Lamp Length' to 60 degrees. This
will make it easier to see where the spotlight is pointed.Click Color and change the color to
yellow. This will distinguish light cast by the spotlight from the point light.Click Create Lamp and
place the spotlight on the side wall.Next, make a point light:Open the 'Light Fixtures' dialog again
and select the 'Point' tab.Click Color and change the color to white.Click Create Lamp and place
the point light on the side wall, away from the spotlight.Render again. ( )Spotlight and point
lightSpotlight and point light effectStep 6 - Aim the spotlightAiming the lamp.To aim a lamp, right
click on a lamp, and select IRender:: Aim LampThe lamp will automatically point at the cursor
position.Snap the cursor to a face, edge, etc. at which you want to point the lamp.Click the left
mouse button to point the lamp, or click escape to stop the operation.Render to see the effect of
the aimed lamp.Step 7. - Create a ceiling lightAdd a ceiling and a left hand wall.Open the 'Light
Fixtures' dialog again and select the 'Ceiling' tab.Click Create Lamp and place the rectangular
light on the ceiling.Render again. ( )Adding a ceiling lightRaytrace of ceiling lightSummaryThis
tutorial showed you how to add reflection and lights to a SketchUp model.You can improve the
final result by adding additional lights, placing a material on the walls, etc.See the other tutorials
for more information on reflection and lights.Rendering OverviewIRender nXt creates stunning
life-like images from SketchUp models. IRender nXt uses Ray Tracing and photometric
rendering technologies from inside SketchUp to create high-quality photo-realistic images from
3D Models.Rendering by Surya Murali using nXt EngineWith IRender nXt, creating presentation
quality images from SketchUp models is easy. Simply add materials, lights, sun, sky and then
render the model.General FeaturesEasy to use, works seamlessly inside SketchUp, and
provides a host of features that speed and simplify image rendering.Uses both raytracing and
Indirect Lighting to create sophisticated single-frame images and animations.Automatically
calculates indirect light, hard and soft shadows, color bleeding, reflections, translucency,
transparency, refraction, highlight, depth of field, and depth attenuation.Supports
multiprocessors and background processing.Includes mathematically generated 3-D plants with
seasonal variation, giving realistic plants, shadows, and reflections.Works inside SketchUp.
Render changes to the model immediately. You never need to export or start over.Progressive-
refinement rendering algorithms with on-screen preview.Save and restore plant, exposure, sun
and sky, and environment settings.Graphical library browsers for materials and plants.RPC 3D



Object support.Post-processing for quick adjustment of brightness, Lighting Channels, fog,
glare, and depth of field.Basic Lighting and ReflectionA user asked for some ideas on how to
improve renderings.Here a some tips which will be helpful when you are just starting
out.OverviewWe would all like a solution where we just take our SketchUp model, click Render
and get a great result.IRender nXt does a surprisingly good hob of this for basic exteriors, using
the High Dynamic, or Exterior lighting presets.However, especially for interiors, you need to add
lights and set special material parameters - such as reflection in order to get a good rendering.
This article will help you learn how to do this.Basic ModelFor these samples, we downloaded a
Vanity and a Shower from the 3D WarehouseI placed the vanity in a room in SketchUp and
Rendered it.SketchUp ModelRendered ModelAdding LightsThe rendered images isn't much
better than the SketchUp image.That is because, especially for interior scenes, you need to add
lights and reflections in order to get a realistic image.First I added some ceiling lights using the
Lighting Wizard.Placing Ceiling LightsJust these lights improved the rendering
significantly.Vanity with overhead lightingAdding ReflectionsOf course we need to make the
mirror reflective. But making the walls reflective will add realistic detail as well.To make a surface
reflective, right click on the material and load the Material Editor:Making the floor
reflectiveRendering with floor, walls and mirror reflectiveI used default reflection for the right
hand wall the first time. But it was too reflective, so I cut the intensity down from 60% to 40% to
make it more subtle.HighlightsReflection and Highlights are similar. Highlights are reflections
directly from lights, rather than reflection of other objects. They add to the realism of a
scene.Here I added reflection to everything which might reflect or create highlights.(See the
highlight in the faucet, even though there is not much reflection.)Reflection and Highlights on
CounterSomething to ReflectAnother important consideration is having something to reflect.In
the scenes above with have a reflective mirror, but nothing interesting to reflect.I added the
shower from the 3D warehouse to the part of the room behind the camera, to make the scene
more interesting.Mirror with reflection of showerAdditioan Texture FeaturesThe images above all
used standard SketchUp materials.Arroway TexturesYou can get more realistic results by using
better materials. For example, Arroway provides a library of textures, (not for free), which have
special shading features for more realistic highlights and reflections.A Wood Floor rendered
from an Arroway TextureThese textures can be imported into SketchUp and used with IRender
nXt.Shiny, Blurry and Glossy ReflectionsIn addition to the amount of reflection on surface, you
can also adjust its shininess.In this example, I made the faucets white ao you could see more
detailed reflection.Faucet with shiny reflectionFor certain surfaces, like brushed metal, tile floors
or wood, the reflection is often blurry rather than shiny. Here I lowered the shininess to 25%
(from 100%) to get a blurry reflection.Blurry reflections require more rendering passes because
the blurriness is achieved by using different, random, angles for reflection on each pass.Faucet
with Blurry reflectionGlossy reflection allows the highlights, but no specific reflection of other
objects. It is done quickly and does not require additional passes.Faucet with Glossy
ReflectionLighting channelsAnother feature which can save time, and make it easy to balance



various lights in Lighting Channels.Here I have added some sconces above the Vanity, and re-
rendered the sceneDefault Balanced LightingHere I have slid the intensity of the Ceiling Lights
down to 10%, which makes the sconces much brighter.Ceiling Lights turned down to 10%Here I
have restored the ceiling lights, but lowered the intensity of the sconces to 10%Sconces at
10%You can't appreciate from just viewing this on line how fast and easy it is to balance lighting
with slider bars as the light intensities change immediately on your screen.SummaryYou can get
get good results easily, just by adding some ceiling ligtts and basic reflection to materials. But for
even better results, you need to render the model, take a look, and adjust the material
parameters and lights to get the effect you want.Check out our for more information in how to do
this.Tutorials and VideosFirst Exterior Rendering VideoFirst Exterior RenderingThis Video
Tutorial explains how to use IRender nXt to create a high-quality, photo-realistic rendering from
your SketchUp model, with out making any changes to the model, or adjusting any rendering
settings.Simple Rendering of an Object VideoSimple Rendering of an ObjectMake great
renderings with out making any changes to the model, or adjusting any rendering settings.Basic
RoomFeatures VideoIRender nXt Features VideoThis video Tutorial, IRender nXt Features,
explains some Basic Features of IRender nXt.Advanced Features VideoAdvanced IRender nXt
Features VideoThis video Tutorial explains some Advanced Features of IRender nXt.Interior
Lighting BasicsInterior Lighting Basics VideoFine-tuned lighting is the key to creating great-
looking interior and nighttime scenes. In this video tutorial we show you how to quickly add lights
to a room and adjust their render settings for a beautiful final imageLIghting Channels
VideoLighting Channels VideoLighting Channels are used to adjust the brightness of light
sources - such as the sun and sky and interior lights.This video shows you how to quickly adjust
the lights while rendering your SketchUp model with IRender nXt.Rendering with Edge Lines
VideoRendering with Edge Lines VideoThis video Tutorial explains how to render a scene with
edge lines visible. Sometimes, details can be washed out in some renderings. Rendering with
edge lines turned on in IRender nXt can bring back many of those lost details.Reflection
Settings VideoReflection Settings VideoHighlights and surface reflections are the best way to
add realism to your renderings and they're easy to create in IRender nXt.In this video tutorial we
show you how to add reflection to objects and materials and fine-tune their settings for a
beautiful, and realistic, result.Glass Transparency VideoGlass Transparency VideoRealistic
transparencies are easy to create in IRender nXt and can be fined tuned for great results. In this
video tutorial we explain how transparency, refraction and intensity settings effect the
transparent objects in your model.How to choose a renderer VideoHow to choose a renderer
VideoThis video highlights SketchUp features which some renderers may not be able to
handle.Multipass rendering VideoMutli Pass Rendering Technology VideoThis video, taken from
a Webinar for the nXtRender/IRender/AccuRender nXt Engine explains some of the advantages
of multi-pass rendering.First Exterior RenderingThis First Exterior Rendering Video explains how
to use IRender nXt to create a high-quality, photo-realistic rendering from your SketchUp
model.First Exterior Rendering VideoFirst Exterior RenderingThis Video Tutorial explains how to



use IRender nXt to create a high-quality, photo-realistic rendering from your SketchUp model,
with out making any changes to the model, or adjusting any rendering settings.*Select model
from 3D warehouseSelect desired viewOne Click to Renderer buttonExplains rendering
passesCompares final image to original SketchUp rendering.No changes made to model or
settingsLater tutorials will explain how to improve the output by making alterations to the model
and changing rendering settings. However, this video shows how you can get great results with
minimal effort.If you want to try a rendering with this same model, search for "Porch for our
Home" on the 3D Warehouse, or use this link directly:TutorialStep 1 - Download and Install
IRender nXtDownload IRender nXt from ourInstall itStep 2 - Download model from the 3D
WarehouseDownloadYou can download it directly from the 3D Warehouse, before starting
SketchUp, or download it directly into SketchUp from the File/3D Warehouse menu.Ranch
House in 3D WarehouseThis is just a model from the Warehouse which we found. It has no
special settings in for rendering.We chose it because it has a porch which will show some of the
subtle shadow effects of IRender nXt.Step 3 - Start SketchUp and load the modelRotate and
Zoom to a view similar to this, so we can see the shading in the porch.Porch ViewClick the
Green Rendering Button to start the rendering.For your first rendering, a dialog will come up with
some rendering parameters.Rendering ParametersSelect Studio - High Dynamic Lighting.This
produces a subtle shadow effect of sunlight filtering through a forest which is good for a lot of
exterior scenes.Select a rendering size - small or medium is good when first working with a
model.And, click the Start Rendering button.Step 4 - Examine your first renderingIt will take a
short time to extract your geometry from the SketchUp model.Rendering PassesYour first model
will render for the default number of 20 passes. The more passes you use, the better the
rendering will get.During those passes, random light is brought in from the Sun and Sky.After
just 5 passes, the rendering is rough - because you can see individual shadows from random
points in the sky.Rendering after 5 passesAfter 20 passes you get a pretty good image as the
lighting converges.Rendering after 20 passesAfter 100 or 200 passes the lighting will smooth
out and you will get an even better rendering.Rendering after 200 passesThis 200 pass took
only about 6 minutes, with a fairly simple model.You should just use about 5 passes for exterior
models until you are happy with your model and your rendering settings. Then you may want to
let them render longer - even overnight - for really great results.Simple Rendering of an Object
VideoThis video Tutorial, Simple Rendering of an Object, explains how to create a high-quality,
photo-realistic renderings from a SketchUp model using IRender nXt.Simple Rendering of an
ObjectMake great renderings with out making any changes to the model, or adjusting any
rendering settings.Learn how to:Download a model from the 3D Warehouse, (not a model
uploaded specially for this video)Render it with no changes to the modelNo special rendering
settings.This shows how easy it is to use IRender nXt, even with no changes to your model.(Of
course, you can make even better renderings by adding lights, material settings, etc.(You will
learn how to do that in later videos.)One Click Render ButtonRendering PassesCompare final
image to original SketchUp imageLater tutorials will explain how to improve the output by making



alterations to the model and changing rendering settings. However, this video shows how you
can get great results with minimal effort.Features VideoIn this IRender nXt Features Video
Dennis explains the value of each of these features and shows you how to use them.IRender nXt
seamless SketchUp integration, lighting and material settings makes it easy to render
photorealistic images.IRender nXt Features VideoThis video Tutorial, IRender nXt Features,
explains some Basic Features of IRender nXt.*Advanced IRender nXt Features VideoAdvanced
IRender nXt Features VideoThis video Tutorial explains some Advanced Features of IRender
nXt.*Depth of FieldLighting ChannelsMaterial EditorMaterial LibrariesIndirect
LightingPanoramasIn this video Dennis explains the value of each of these features and shows
you haw to use them.Depth of Field, Lighting Channels, Material Editor, Material Libraries,
Indirect Lighting, Panoramas .See: Advanced IRender nXt FeaturesInterior Lighting BasicsThe
Interior Lighting Basics Video sets up basic lights for SketchUp Rendering.Interior Lighting
Basics VideoFine-tuned lighting is the key to creating great-looking interior and nighttime
scenes. In this video tutorial we show you how to quickly add lights to a room and adjust their
render settings for a beautiful final imageThis video Tutorial, Interior Lighting Basics, explains
how to quickly render a room setting with a basic lighting set up. It goes over how to place a
ceiling light, a floor lamp as well as making your own lights. Also, covers how to adjust a few
settings to improve the final image. This shows how quickly you can put IRender nXt to
work.'Ceiling LightsFloor LampCreate your own lampLater tutorials will explain how to add
additional lighting types.Lighting Channels Video.Watch our video tutorial, Lighting Channels, to
learn how to adjust the lighting in your Sketch Up rendering using IRender nXt.Lighting
Channels Video
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